Написать программу, сокращающую обыкновенные дроби. числитель и знаменатель вводятся с клавиатуры. в программе использовать цикл с постусловием. пример. вводятся числа: 10 15 результат: 2 / 3

Мариянадубу Мариянадубу    2   30.03.2019 17:30    5

Ответы
Крайз Крайз  27.05.2020 18:14

var i,x,y:integer;
b:boolean;
begin
readln(x,y);
for i:=2 to x do
if (x div i=x/i) and (y div i=y/i) then begin
x:=x div i;
y:=y div i;
end;
writeln(x,' ',y);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика