Написать программу: Сформировать одномерный массив, где элементы массива - целые числа в пределах от -10 до 10. Найти максимальный элемент в массиве.

vihshgfgvf vihshgfgvf    1   10.12.2021 09:17    2

Ответы
Elkhadi54Skorpion Elkhadi54Skorpion  30.01.2022 06:58

var

 a:array of integer;

 i,n,max:integer;

begin

 write('Кол-во эл. в массиве: '); readln(n);

 max:=-20;

 setlength(a,n);

 for i:=0 to n-1 do

   begin

     a[i]:=random(21)-10;

     write(a[i],' ');

     if a[i]>max then  

       max:=a[i];

   end;

 writeln;

 writeln('Max: ',max);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика