Написать программу с указанным интерфейсом, вычисляющую сумму и среднее арифметическое трех чисел:

Введите три числа:
<Пользователь вводит, например: 6 8 2 >
Сумма = 16 Среднее арифметическое = 5,3333

vika0289111 vika0289111    3   29.03.2020 10:14    2

Ответы
Tolyashasorokin Tolyashasorokin  11.09.2020 22:54

program aeifmerik;

var

a, b, c, d: real;

begin

writeln('введите три числа(если не целые,то с точкой,а не запятой)');

readln(a, b, c);

d := (a + b + c) / 3;

writeln('ваша сумма равна ', a + b + c);

writeln('среднее арифметическое равно ', d: 6: 2);

end.

Объяснение:

если среднее арифметическое нужно округлить,то Можно в последней строчке после д сделать так:

d:6:2

тогда после запятой будет только 2 знака.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика