Написать программу (с program. var и тд) дано семизначное число. найти сумму,произведение и среднее арифметическое этих цифр

wagnercop06s12 wagnercop06s12    1   18.09.2019 01:20    2

Ответы
НикаНик1111 НикаНик1111  07.10.2020 23:01
Var a,b,i,s,p:integer;
begin
readln(a);
s:=0; p:=1;
for i:=1 to 7 do
 begin
 b:=a mod 10;
 s:=s+b;
 p:=p*b;
 a:=a div 10;
 end;
writeln('s = ',s,' p = ',p,' sr = ',s/7:5:2);
end.

Пример:
1389546
s = 36 p = 25920 sr = 5.14
ПОКАЗАТЬ ОТВЕТЫ
хорошист547 хорошист547  07.10.2020 23:01
Программа прикреплена в приложении

Примеры:

Введите семизначное число: 4564564
Среднее арифметическое цифр числа: 4.85714

Введите семизначное число: 6535684
Среднее арифметическое цифр числа: 5.29

Введите семизначное число: 6563258
Среднее арифметическое цифр числа: 5.00
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика