Написать программу с одномерным массивом, которое находит средне арифметическое ​

dahasha0515ozg6qu dahasha0515ozg6qu    1   11.04.2019 06:15    2

Ответы
френки9 френки9  29.05.2020 06:15

program ;

uses crt;

var

a:array[1..100] of integer;

i:integer;

s:real;

begin

clrscr;

randomize;

for i:=1 to 100 do

  begin

  a[i] := random(100)+1;

  s:=s+a[i];

  end;

s:=s/100;

writeln(s:20:2);

end.

Объяснение:

Массив 'a' заполняется рандомными числами в цикле for, где параллельно с этим в переменную 's' добавляется значения массива с индексом 'i'. После цикла 's' делиться на 100 тем самым получая среднее арифметическое, а после результат выводится.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика