Написать программу с объяснением (pascalabc) даны первые 4 строки: 1) 1 2) 112 3) 1121123 4) 112112311211234 и т. д. написать программу выводящую n строку (n< =20)

veronikak3602 veronikak3602    3   31.07.2019 07:10    6

Ответы
arshin1 arshin1  25.08.2020 17:04
Заметим, чтобы сгенерировать строку, нужно знать только предыдущую строку. Будет генерировать по порядку от 1 до n-ой строки.

Программа:

var
  n, i: integer;
  cur_str, prev_str: string;
begin
  read(n);
  prev_str := '';
  for i := 1 to n do {Генерируем строки по порядку от 1 до n}
  begin
    str(i, cur_str); {Записываем в текущую строку её порядковый номер}
    cur_str := prev_str + prev_str + cur_str; {Дописываем предыдущую строку два раза в начало}
    prev_str := cur_str; {Записываем текущею строку вместо предудущей}
  end;
  writeln(cur_str);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика