Написать программу с использованием процедуры или функции. объявлен массив целых чисел. m размером 5х10. заполнить массив числами из промежутка [-20,20]. каждый элемент массива заменить его кубом. исходный и измененный массив вывести на экран. возведение в 3 степень организовать с функции или процедуры

Olyakiti Olyakiti    2   17.03.2019 22:00    7

Ответы
egormatkarimov egormatkarimov  25.05.2020 21:29

type
  Mas = array [1..5, 1..10] of integer; //Объявляем тип массива

 

var
  m: Mas;  //Переменная типа массива
  i, j: integer;  //Переменные для цикла

 

procedure CubeMas(var m: Mas); //Процедура возведения в куб
var
  i, j: integer;  //Локальные переменные цикла в процедуре

begin
  write('Измененный массив: ');
  for i:= 1 to 5 do
    for j:= 1 to 10 do
    begin
      m[i, j]:= sqr(m[i, j]) * m[i, j];  //Возводим элемент массива в куб
      write('m[', i, ', ', j, '] = ', m[i, j], '  ');  //Печатаем элемент массива
    end;  //Конец цикла
  writeln;  //Перевод на новую строку
end;  //Конец процедуры

 

begin
  write('Исходный массив: ');
  for i:= 1 to 5 do
    for j:= 1 to 10 do
    begin
      m[i, j]:= random(40) - 20;  {Присваиваем элементу массива случайное значение из промежутка [-20, 20] }
      write('m[', i, ', ', j, '] = ', m[i, j], '  ');  //Печатаем элемент массива
    end;  //Конец цикла
  writeln;  //Перевод на новую строку
  CubeMas(m);  //Вызываем процедуру возведения в куб
end. //Конец программы

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика