Написать программу с использованием оператора while do вот в начале тренировочного периода лыжник во время тренировки пробегал 5 км,каждый день он увеличивал нагрузку на 5%.рассчитать через какое время нагрузка лыжника во время тренировки превысит 20км

77Stranik77 77Stranik77    2   13.06.2019 22:20    6

Ответы
tapilina92 tapilina92  10.07.2020 19:16
Лучше перепроверить.
ПОКАЗАТЬ ОТВЕТЫ
idiotizROSSII idiotizROSSII  10.07.2020 19:16
Var 
a, b, c, summ, d, den:real;
beginwrite('Введите кол-во км начальные: ');readln(a);
write('Введите на сколько % увеличивается расстояние каждый день: ');readln(b);
write('Введите, до скольки КМ увеличивает расстояние в день лыжник: ');readln(c);

den:=0;
while a<c do begin  d:=a/100*b; // узнаем, на сколько увеличивается растояние  a:=a+d;  den:=den+1;  end;     writeln(den);
end.

Написал на Pascal. Вводить можно любые данные ( не только, которые вы дали)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика