Написать программу с использованием оператора цикла(постусловия). резервуар имеет форму сферы; его внутренний радиус равен r см найдите объем(v) жидкости в зависимости от от уровня h воды от низшей точки его дна. величина h изменяется от 0 до 2 с шагом 0,1. объем v шарового сегмента (заполненого жидкостью) вычисляется по формуле πh²(r-h/3).

anna3371 anna3371    3   15.06.2019 03:00    1

Ответы
darinaprokopenk darinaprokopenk  12.07.2020 12:32
 const
  pi=3.14;
 var
  h,V,R: real;
begin
 writeln('Введите радиус');
 Readln(R);
 h:=0;
 repeat
   V:=pi*sqr(h)*(R-h/3);
   writeln('V(',h,')=', V);
   h:=h+0.1;
 until h>2.1;
 end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика