Написать программу с использованием цикла с постусловием рараметром и составит и блок схемы дано натуральное число определить количество его нечетеых делителей

нтпрои нтпрои    2   23.07.2019 00:50    1

Ответы
asemk85 asemk85  03.10.2020 11:15
Program dividers;
var
    c,i,n :Integer;
begin
     readln(n);
     repeat
          if ( (n mod i) = 0 ) and ( (i mod 2) <> 0) then c:= c + 1;
          if  ( (n / i) mod 2) <> 0 then c:= c + 1;
          i:= i + 1;
     until i < (sqrt(n) + 1);
     writeln(c);
end.
   
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика