Написать программу решения : вводить целые числа с клавиатуры, пока не будет введен ноль. а) найти сумму введенных чисел. b) найти количество четных отрицательных чисел среди введенных. c) найти максимальное число среди введенных.

respons respons    1   25.08.2019 04:50    6

Ответы
ксения282006 ксения282006  14.08.2020 19:53
//PascalABC.Net 3.2
begin
var max:=-1000000000;
var sum:=0; var count:=0; var a:=0;
repeat
a:=readinteger('Введите число: ');
if (a.IsEven) and (a<0) then inc(count);
if a>max then max:=a;
sum+=a;
until a=0;
writeln ('a) ', sum);
writeln ('b) ', count);
write  ('c) ', max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика