Написать программу решения : дано натуральное число n и цифра a. написать программу, определяющую: а) количество цифр в числе; b) равна ли первая цифра числа последней цифре; с) входит ли цифра a в запись этого числа.

alenashafeeva alenashafeeva    1   11.07.2019 22:30    2

Ответы
AllRay1 AllRay1  15.09.2020 13:20
// PascalABC.NET 3.0, сборка 1088
begin
  var n:=ReadLnString('Введите число: ');
  n:=n.Where(x->x in ['0'..'9']).JoinIntoString('');
  Writeln('Принятое число: ',n);
  var a:=ReadLnChar('Введите искомую цифру: ');
  Writeln('Количество цифр в числе равно ',n.Length);
  if n[1]=n[n.Length] then Writeln('Первая цифра равна последней')
  else Writeln('Первая цифра не равна последней');
  if Pos(a,n)>0 then Writeln('Цифра ',a,' входит в число')
  else Writeln('Цифра ',a,' не входит в число')
end.

Тестовое решение:
Введите число: тут спрятано 456. по частям 764 наше 03число
Принятое число: 45676403
Введите искомую цифру: 0
Количество цифр в числе равно 8
Первая цифра не равна последней
Цифра 0 входит в число

"Школьный вариант"
// PascalABC.NET 3.0, сборка 1088
var
  n:longint;
  i,k:integer;
  sn:string;
  a:char;
begin
  Write('Введите число: '); Readln(n);
  Str(n,sn);
  Write('Введите искомую цифру: '); Readln(a);
  k:=Length(sn);
  Writeln('Количество цифр в числе равно ',k);
  if sn[1]=sn[k] then Writeln('Первая цифра равна последней')
  else Writeln('Первая цифра не равна последней');
  if Pos(a,sn)>0 then Writeln('Цифра ',a,' входит в число')
  else Writeln('Цифра ',a,' не входит в число')
end.

Тестовое решение:
Введите число: 3476573
Введите искомую цифру: 7
Количество цифр в числе равно 7
Первая цифра равна последней
Цифра 7 входит в число
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика