Написать программу, решающую : вася имеет х рублей на карманные расходы. сколько банок газировки он сможет купить, если газировка стоит y рублей.

alesa12102006 alesa12102006    2   28.01.2020 12:14    4

Ответы
FoxEdit FoxEdit  11.10.2020 03:53

var money, price, count: integer;

begin

 writeln('Введите количество денег и стоимость одной газировки');

 readln(money, price);

 count := 0;

 if(money >= price) then begin repeat

   money := money - price;

   inc(count, 1);

 until money < price;  

 writeln('Петя может купить ', count, ' банок газировки');

 end else writeln('Вася не может купить газировку.');

end.

Объяснение:

1) Создаём переменные

money - количество денег у Васи.

price - цена одной газировки.

count - количество банок после покупки.

2) Запрашиваем сумму денег Васи.

3) Проверяем количество денег, если у Васи денег меньше чем цена одной газировки, то говорим пользователю, что Вася не может купить газировку.

4) Через цикл получаем количество банок и выводим ответ.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика