tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу, распознающую
Написать программу, распознающую по длинам сторон среди всех треугольников прямоугольный. если таковых нет, то вычислить величину угла с. (паскаль) с объяснением, если можно. заранее .
eliot40
1 21.08.2019 00:40
20
Ответы
selix2017
31.08.2020 18:55
//искать угол будем по теореме косинусов
Program n1;
var x,y,z:real;
function arccos(x : real) : real; {это понадобится для теор. кос.}
begin
arccos := 2 * arctan(sqrt((1 - x) / (1 + x)));
end;
procedure ygl( a,b,c: real); {процедура для удобства}
var ga: real;
begin
ga:=arccos((sqr(a) + sqr(b) - sqr(c))/(2 * a* b)) * 180 / pi; {сама теор. кос.}
writeln('угол С= ',ga:5:2);
end;
begin
write('введите сторону а: ');
readln(x);
write('введите сторону b: ');
readln(y);
write('введите сторону c: ');
readln(z);
if(x>=y+z)or(y>=x+z)or(z>=x+y)then writeln('Это не треугольник')
else if x*x+y*y=z*z then {теорема пифагора}
writeln('Это прямоугольный треугольник')
else if (x*x+y*y>z*z)and(x*x+z*z>y*y)and(z*z+y*y>x*x)
then
begin
writeln('Это остроугольный треугольник');
ygl(x,y,z); {вызываем процедуру}
end
else
begin
writeln('Это тупоугольный треугольник');
ygl(x,y,z);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
xarimapula
12.04.2021 17:50
Выведи на экран большее из двух данных чисел. Запиши программу на языке Паскаль, выведи ответ на экран, если 1.45871 и 2.4578....
кристина2162
23.11.2020 10:42
ответьте на вопросы - Назови виды компьютерной графики.- Из чего состоит растровая графика?- Из чего состоит векторная графики?- Какому виду графики свойственен большой объем?- Какому...
SOV20
23.11.2020 10:42
сколько различных сообщений может быть передано за n микросекунд используя 6 различных сигналов, если 2 сигнала требуют 3 микросекунды для своей передачи, сигналы следуют один за...
bizi2002
23.11.2020 10:44
Получено сообщение, информационный объём которого равен 4096 бит. Чему равен информационный объём этого сообщения в килобайтах?...
Улаган
10.09.2020 10:15
в чём различие между точностью ценностью Когда мама говорит завтра вечером приедет бабушка и привезёт тебе подарок из отпуска...
jzzy
13.04.2020 12:59
1. На диаграмме 1 показаны значения напряжения U между концами цилиндрических медных проводников 1 и 2 одинаковой длины, а на диаграмме 2 – площади S их поперечного сечения. Сравните...
nkarakulina
13.04.2020 12:59
Вариант № 1 1. Ниже приведена программа. s = int(input()) t = int(input()) if s 6 and t 7: print( YES ) else: print( NO ) Было проведено 9 запусков программы, при которых в качестве...
данил2048
13.04.2020 12:59
Автобус и грузовая машина, скорость которой на 15 км/ч больше скорости автобуса, выехали одновременно навстречу друг другу из двух городов, расстояние между которыми — 548 км. Определи...
knyazik2003
13.04.2020 12:59
От Для выборки кошелькового невода неводовыборочная машина с электрическим приводом развивает мощность, равную 4 кВт. За сколько времени она выберет невод длиной 1000 м при силе тяги...
arnautovvladik
13.04.2020 12:59
Кто, по – вашему, и почему является главным героем 1 части трилогии Л.Н. Толстого «Детство»?...
Популярные вопросы
Вданные предложения включите приложения. расставьте знаки препинания. 1) он в служебных...
3
Участник состязаний в беге.кулачному бою и т д...
1
Сколько целых чисел, которые а)больше 1,но меньше 7.б)больше -1, но меньше 7.в)больше...
3
Придумать заключение! в данном тексте ю. трофимов поднимает проблему гуманного...
2
Одна шестая числа равна 12.найти это число...
1
Определить к какой средеопределить к какой среде (кислотной или щелочной) относятся...
3
Как будет выглядеть график функции у = sin(п - х) и почему?...
1
Діалог по анг. мові по ураїну. рівень 5 клас ( 6-8речень)....
3
Перестройте предложение так,чтобы сказуемое стало обособленным приложением.дополните...
3
Abcd - параллелограмм. найдите координаты точки d, если a(-4; 3),b(5; 0),c(5; 3)....
1
Program n1;
var x,y,z:real;
function arccos(x : real) : real; {это понадобится для теор. кос.}
begin
arccos := 2 * arctan(sqrt((1 - x) / (1 + x)));
end;
procedure ygl( a,b,c: real); {процедура для удобства}
var ga: real;
begin
ga:=arccos((sqr(a) + sqr(b) - sqr(c))/(2 * a* b)) * 180 / pi; {сама теор. кос.}
writeln('угол С= ',ga:5:2);
end;
begin
write('введите сторону а: ');
readln(x);
write('введите сторону b: ');
readln(y);
write('введите сторону c: ');
readln(z);
if(x>=y+z)or(y>=x+z)or(z>=x+y)then writeln('Это не треугольник')
else if x*x+y*y=z*z then {теорема пифагора}
writeln('Это прямоугольный треугольник')
else if (x*x+y*y>z*z)and(x*x+z*z>y*y)and(z*z+y*y>x*x)
then
begin
writeln('Это остроугольный треугольник');
ygl(x,y,z); {вызываем процедуру}
end
else
begin
writeln('Это тупоугольный треугольник');
ygl(x,y,z);
end;
end.