Написать программу: при вводе числа в двоичной системе нужно посчитать количество нолей и единиц а при вводе числа больше 1 будет выдавать error​

сымбат64 сымбат64    1   20.05.2019 07:01    2

Ответы
Superpuper228911 Superpuper228911  13.06.2020 15:40

На Python:

number = input('Введите число в двоичной системе счисления: ')

number_of_zeros = 0

number_of_units = 0

for i in number:

   if i == '0':

       number_of_zeros += 1

   elif i == '1':

       number_of_units += 1

try:

#    print('Введеное число: ' + str(int(number, 2)))

   print('Нулей: ' + str(number_of_zeros))

   print('Единиц: ' + str(number_of_units))

except ValueError:

   print('Error')

Объяснение:

закомментировал строку вывода числа в десятичной системе, если понадобится, можно раскомментировать (убрать #), если совсем не надо, можно удалить.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика