Написать программу позволяющую по последней цифре числа определить последнюю цифру его квадрата

DetasGames DetasGames    2   31.03.2019 11:50    18

Ответы
BegimaiAnarkulova BegimaiAnarkulova  27.05.2020 22:10

все просто, что бы определить какой цифрой закончится число, надо взять последнюю цифру этого числа и возвести ее в квадрат. Затем, если число двузначное, то ответом будет послденяя цифра поученного числа или если число однозначное, то оно и будет ответом.
 var a:integer; 
begin 
read(a); 
write(sqr(a) mod 10); 
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика