Написать программу,позволяющую для заданного одномерного массива а из n вещественных или целых элементов реализовать обработку массива.длина массива n задается пользователем как константное выражение.исходные данные задать вручную или с генератора случайных чисел,учитывая формат элементов массива а.тип результата определяется из контекста. -вычислить количество отрицательных элементов массива; -сумму модулей элементов массива,расположенных после максимального элемента

nika55551 nika55551    3   17.06.2019 08:50    4

Ответы
dashechka1707 dashechka1707  02.10.2020 03:24
Const n=
var a:array [1..n] of integer; (целый)
i,k, i_max: byte; max, sum:integer;
begin
randomize;    или          for i:=1 to n do
for i:=1 to n do              readln(a[i]);
a[i]:=random (100);
k:=0
for i:=1 to n do
if a[i]<0 then k:=k+1];
max:=0; i_max:=0;
for i:=1 to n do
if a[i]>max then begin max:=a[i]; i_max:=i; end;
sum:=0;
for i:=i_max to n do
sum:=sum+a[i];
writeln('Количество отрицательных элементов ',k);
writeln('Сумма элементов ', sum);
readln;
end.

 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика