Написать программу посчитывающую в массиве сумму элементов меньших 0 ,их количество и средее значение

soos4 soos4    1   27.06.2019 14:20    4

Ответы
ЯхочуВхогвартс ЯхочуВхогвартс  21.07.2020 23:53
У меня получилась такая программка:

uses Crt;
const n=15;
type Vec=array [1..n] of integer ;
var i, SumOtr, ColOtr: integer;
    A: Vec ;
begin
ClrScr;
Randomize;
SumOtr:=0;
ColOtr:=0;
WriteLn (' Massiv A: ');
for i:=1 to n do
    begin
       A[i]:=-10+random(20);
       if A[i]<0  then
          begin
             SumOtr:=SumOtr+A[i];
             ColOtr:=ColOtr+1;
          end;
       Write (A[i]:4);
    end;
WriteLn;
WriteLn('ColOtr = ', ColOtr);
WriteLn('SumOtr = ', SumOtr);
WriteLn('SredOtr = ', SumOtr/ColOtr:4:2);
ReadLn;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика