Написать программу пользователь вводит 5 целых чисел,программа находит сумму всех отрицательных и произведение всех положительных чисел

Andriy1208 Andriy1208    2   23.06.2019 10:30    3

Ответы
chvdima chvdima  19.07.2020 10:48
Uses CRT;
var i,s,p,a,n:integer;
begin
  p:=1; 
  write('введите кол-во чисел ');
  readln(n);
  for i:=1 to n do begin
                            write('введите ',i,'число: ');
                            readln(a);
                            if a<0 then s:=s+a
                            else p:=p*a
                          end;
 writeln('сумма отрицательных чисел равна: ',s);
 writeln('произведение всех положительных чисел равно: ',p)
end.
как-то так)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика