Написать программу поиска произведения последовательности отрицательных чисел, вводимых с клавиатуры, предшествующих первому введенному нулю. Контрольный пример: 1,2,3,-4,5,-2,0. С++

natakleymyk natakleymyk    1   23.06.2020 14:45    18

Ответы
ibarabol318 ibarabol318  15.10.2020 14:44

#include <iostream>

#include <vector>

#include <algorithm>

#include <string>

#include <cstdio>

#include <math.h>

using namespace std;

int main() {

long long a, mn;

mn = 1;

cin >> a;

while (a != 0) {

mn *= a;

cin >> a;

}

cout << mn;

return 0;

}

Вроде должно работать, можешь сам протестировать)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика