tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу, подсчитывающую
Написать программу, подсчитывающую количество четных и нечетных цифр в четырехзначном числе . ( в паскале с использованием цикла for)
tatianaradoslav
3 02.06.2019 14:00
2
Ответы
Undina705
03.07.2020 09:51
Var a,b1,b2,c,i:integer;
begin
readln(a);
for i:=1 to 4 do begin
c:=a mod 10;
if c mod 2 = 0 then b1+=1 else
b2+=1;
a:=a div 10;
end;
writeln('Четных - ',b1,' нечетных - ',b2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Messi1444
16.04.2020 19:30
с последними 2умя заданиями. Никак не получается сделать(( 2ое задание подробно расписать 3 указать причину почему неправильно...
nadechdavasilev
16.04.2020 19:31
Внимательно рассмотрите числа в ряду. Найдите лишнее. Будьте готовы обосновать свой ответ. 11,12,13,15, 16,17...
лера1405
18.05.2020 21:22
Входные данные Пять чисел – координаты точки и коэффициенты A, B и C уравнения прямой. Выходные данные Одна строка “YES”, если точка принадлежит прямой, и “NO” в...
Dasha5901
11.08.2019 13:30
Инф. сообщение объемом 375 байт состоит из 500 символов. каков информационный вес каждого символа этого сообщения? какова мощность алфавита, с которого было записано...
Кактус1313
28.06.2019 21:40
Как выглядит структура объявления переменных?...
lera2934
28.06.2019 21:40
Какая операция не применяется для редактирования текста? а) удаление в тексте неверно набранного символа б) вставка пропущенного символа в) печать текста...
karipzhanovalibek11
28.06.2019 21:40
Вычислите значение выражения: 537,28-ca,216+11011,12 ответ запишите в 16-ричной системе счисления...
xato2003
28.06.2019 21:40
Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный одномерный массив на один элемент...
mrskelet7
30.06.2019 18:20
Дiалог на тему займенник наприклад -як тобi тема займенник? -мени вона дуже . ця тема дуже легка та iнтересна...
fkghdk
30.06.2019 18:20
5. значение дыхания состоит в обеспечении организма 1)энергией 2)строительным материалом 3)запасными питательными веществами 4)витаминами...
Популярные вопросы
Определите, что будет напечатано в результате работы следующего...
1
Розповідь якби звірі могли розмовляти...
3
Из перечиленных кислот назавите самую сильную кислоту и обяснить...
2
Апофема правильной четырёхугольной пирамиды равна 3 см, её высота...
1
Составьте уравнения реакций при которых можно осуществить следующие...
2
Берлинский стена в официальных источниках гдр была известна как...
3
Составить пять общих и шесть специальных вопросов на...
2
Найди правильный вариант расстоновки знаков препинания в предложении....
1
Указать реактив на сульфат ион написать уравнения реакции в молекулярном...
1
Решите на множестве r уровнение: а) (x-15)(x-65,8)=0 в) (x-3,7)(x-9,8)=0...
1
begin
readln(a);
for i:=1 to 4 do begin
c:=a mod 10;
if c mod 2 = 0 then b1+=1 else
b2+=1;
a:=a div 10;
end;
writeln('Четных - ',b1,' нечетных - ',b2);
end.