Написать программу. подсчитать количество жильцов дома в котором 36 квартир(в квартире проживает от 1 до 10 человек) и найти номер квартиры в которой проживает наибольшее количество жильцов.

mdior10 mdior10    2   23.08.2019 07:20    3

Ответы
о23072005 о23072005  05.10.2020 14:07
/ PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Поквартирная численность жильцов');
  var a:=ArrRandom(36,1,10); a.Println;
  var mx:=a.Max;
  Write('Квартиры с максимальным количеством жильцов: ');
  a.Select((x,i)->(x,i)).Where(x->x[0]=mx).Select(x->x[1]+1).Println
end.

Пример
Поквартирная численность жильцов
7 9 6 7 8 9 1 4 7 8 8 8 1 7 7 8 3 10 7 7 2 9 7 3 2 8 2 2 10 4 4 5 2 1 7 1
Квартиры с максимальным количеством жильцов: 18 29
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика