Написать программу по которой машина переставит местами первую и вторую половину введенного слова

Brosherin Brosherin    2   11.07.2019 22:00    1

Ответы
iljarybackov20 iljarybackov20  17.09.2020 23:59
var   s : string[50];
  i, j, k : word;  
 f : boolean;  
function isSpace(ch : char) : boolean;
begin   isSpace := false;  
if ch = ' ' then isSpace := true;
end;  
begin   f := false;  
   repeat     j := 0;
    writeln('введите строку, состоящую из 2 слов');
    readln(s);    
for i := 1 to length(s) do    
   if isSpace(s[i]) then  
    begin    
     inc(j);      
   k := i;       end;
     if j =1 then f := true;
    until f;    
write(copy(s, k + 1, length(s)), ' ', copy(s, 1, k - 1)); 
end.
недавно такую писала :)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика