, написать программу по информатике! Определить сколько можно купить арбузов за 1000 рублей.
Цена арбуза (1кг) - 15 руб.,
Вес (Random, Т.е. программа с Randomize) - от 2 до 8 кг.
Желательно, чтобы программа была правильной, если сверятся с программы Паскаля.
​

Алишер00001 Алишер00001    1   20.05.2021 23:32    2

Ответы
wayly wayly  19.06.2021 23:38

var a,b,c:integer;

begin

c:=0;

while b<1000 do begin

c:=c+1;

a:=random(2,8);

b:=b+a*15;

if b>1000 then

c:=c-1;

end;

writeln('можно купить ',c,' ШТ')

end.

ПОКАЗАТЬ ОТВЕТЫ
natapova12 natapova12  19.06.2021 23:38

Что-то вроде такого? Раз для каждого вес рандомный


, написать программу по информатике! Определить сколько можно купить арбузов за 1000 рублей. Цена ар
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика