Написать программу по информатике: найти произведение положительных, сумму и количество отрицательных из 10 введенных целых чисел.

DenisРоссия DenisРоссия    2   17.08.2019 03:10    4

Ответы
Вишеневка123456789 Вишеневка123456789  04.10.2020 23:55
 program ex; 
var a,k,s,pr,i:integer;mas:array [0..10] of integer; 
begin 
pr:=1; 
for i:=1 to 10 do   
readln(mas[i]); 
 for i:=1 to 10 do   begin   
 if mas[i]>0 then   
  pr:=pr*mas[i]   
 else      s:=s+mas[i]; 
 end; 
 for i:=1 to 10 do  
 begin    
if mas[i]<0 then       k:=k+1;    
end; 
writeln('Произведение=',pr);
 writeln('Сумма=',s); 
writeln('Количество=',k) 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика