Написать программу по информатике! дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. верно ли, что все элементы последовательности равны между собой?

ерик12840 ерик12840    2   22.08.2019 00:20    13

Ответы
annashiklo annashiklo  05.10.2020 10:56
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=(SeqRandom(n-1,0,1)+(-1)).ToArray; // последовательность 0 и 1
  a.Println;
  if a.Where(x->x>=0).Distinct.Count>1 then
    Writeln('Есть отличающиеся элементы')
  else Writeln('Все элементы равны')
end.

Примеры
Длина последовательности:  4
1 1 1 -1
Все элементы равны

Длина последовательности:  5
0 1 1 0 -1
Есть отличающиеся элементы
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика