Написать программу паскаля, которая определяет делится ли число на 3 ,но не делятся на две.

Написать программу Паскаля ,которая определяет делится ли число на 5 ​​

SeverinaWinter SeverinaWinter    1   02.02.2021 23:30    8

Ответы
Dilya173 Dilya173  02.02.2021 23:40

В строке №8 записываем операцию умножения.

В строке №10 записываем операцию деления. Ее отличие от операции «Div» в том, делить можно дробные числа и результате операции могут получаться дробные числа. Запомните, что операция деления «/» не производится над переменными целого типа integer, т.к. в результате такой операции могут получиться дробные числа, и программа выдаст ошибку.


Написать программу паскаля, которая определяет делится ли число на 3 ,но не делятся на две.Написать
ПОКАЗАТЬ ОТВЕТЫ
ерикос ерикос  02.02.2021 23:40

3.

program 1;

a:integer;

Begin

write ('a= ');

readln (a);

if (a mod 3=0) then

writeln ('да делится) ;

else

writeln('не делится');

readln;

end.

5.

var n:integer;

begin

write('n=');

readln(n);

if n mod 5=0 then write('Число кратно 5')

else write('Число нужно увеличить на ',5-n mod 5)

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика