Написать программу паскаль - вывести на экран элементы , которые больше значения элемента, номер которого введен с клавиатуры

Какэтимпользоваться Какэтимпользоваться    3   09.06.2019 10:50    340

Ответы
юсуф37 юсуф37  08.07.2020 08:18
Var
  arr : array [1..30] of integer;
  i, number : integer;
begin
  //Заполнение массива случайными числами
  for i := 1 to 30 do
    arr[i] := Random(10000) - 5000;
  //---
  //Считывание номера элемента и проверка на соответствие условию
  write('Введите число: ');
  readln(number);
  if not (number in [1..30]) then
  begin
    write('Ошибка. Номер элемента выходит за границу массива');
    Exit;
  end;
  //---
  //Вывод массива с учётом условия
  for i := 1 to 30 do
    if arr[i] > arr[number] then
      write(arr[i], ' ');
  //---
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика