Написать программу паскаль с клавиатуры вводится три числа- коэффициент квадратного уравнения. сколько решений имеет уравнение !

саша240904 саша240904    3   02.10.2019 10:40    4

Ответы
Lizaveta20021 Lizaveta20021  09.10.2020 11:34

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25



var

 a,b,c: integer;

 x,d: real;

begin

 repeat

   write('Введите коэффициент a (a<>0): ');

   readln(a);

 until a<>0;

 write('Введите коэффициент b: ');

 readln(b);

 write('Введите коэффициент c: ');

 readln(c);

 d:=b*b-4*a*c;

 writeln('Решение уравнения:');

 if d=0 then

   writeln('Корень один: х = ',-b/2/a) else

 if d<0 then

   writeln('Корней на множестве действительных чисел нет') else  

 begin

   writeln('Корней два:');

   writeln('1-й корень: x1 = ',(-b-sqrt(d))/2/a);

   writeln('2-й корень: x1 = ',(-b+sqrt(d))/2/a);

 end;

 readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика