Написать программу паскаль, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла , а вывод - (в скобках указана размерность массива): 1.заменить каждый отрицательный элемент произведением всех ненулевых элементов массива (8);

odyvanchik22 odyvanchik22    2   18.08.2019 14:30    3

Ответы
TaiGaaara TaiGaaara  26.08.2020 06:23
Const
    N = 8;

var
    a: array[1..N] of integer;
    p: integer;
    i: byte;

begin
    writeln('Введите массив из ', N, ' элементов');
    i := 0;
    p := 1;
    
    while i < n do
    begin
        i := i + 1;
        read(a[i]);
        if a[i] <> 0 then p := p * a[i];
    end;
    
    writeln('Отредактированный массив');
    i := 0;
    repeat
        i := i + 1;
        if a[i] < 0 then a[i] := p;
        write(a[i], ' ');
    until i >= n;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика