Написать программу паскаль, которая формирует массив, элементами которого являются цифры заданного натурального числа.

nikita4502 nikita4502    3   08.06.2019 21:00    0

Ответы
метал3 метал3  07.07.2020 21:49
var
  a: array of byte; //char?
  b, d: integer;

begin
  readln(b);
  SetLength(a, length(IntToStr(b)));
  
  for d := 0 to length(a) - 1 do
  begin
    a[d] := b mod 10;
    b := b div 10;
  end;
  
  for d := 0 to (length(a) - 1) do
    write(a[d], ' ');
end. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика