Написать программу Pascal. Найти простые числа х и у, которые в произведении дают число z, типа longint.

voborocha voborocha    1   23.12.2021 04:53    2

Ответы
DenGamer11 DenGamer11  23.12.2021 06:00

число Z вводится

Pascal

var

 i, z: longint;

begin

 write('Введите Z : ');

 readln(z);

 for i:=1 to trunc(sqrt(z)) do begin

   if z mod i = 0 then

     writeln(i, ' * ', z/i);

 end;  

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика