Написать программу pascal, которая выводила бы число в обратной последовательности

haydarakyol1986 haydarakyol1986    3   09.08.2019 12:40    5

Ответы
kdgsteam kdgsteam  04.10.2020 07:18
Procedure Chisla(n : Integer);
var    a : Integer;
begin 
   if (n < 1) then 
WriteLn   
  else 
  begin 
       Read(a);       
if (Abs(a) < 1000) then       
begin           
Chisla(n-1);           
Write(a,' ');       
 end       
else           
 Chisla(n);   
 end;end; function ReadN() : Integer;
var   
n : Integer;begin   
Write('n=');   
ReadLn(n);   
if Not(n in [0..1000]) then       
n := ReadN();   
ReadN := n;end; var   
n : Integer; begin   
n := ReadN();   
WriteLn('Введите ', n, ' целых чисел через пробел и нажмите Enter'); 
   Chisla(n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика