Написать программу Pascal для нахождения наибольшей цифры целого положительного числа. Длина числа до 9 цифр. ​

самая29 самая29    1   15.02.2021 20:16    6

Ответы
zool29 zool29  17.03.2021 20:20

var

 a: string;

 b: array[1..9]of integer;

 sort: boolean;

 max, k: integer;

begin

 Readln(a);

 for var i := 1 to Length(a) do

   b[i] := strtoint(a[i]);

 sort := false;

 while sort = false do

 begin

   sort := true;

   k += 1;

   for var i := 1 to Length(a)-1 do

   begin

     if a[i] < a[i+1] then

     begin

       sort := false;

       var value2 := a[i];

       a[i] := a[i+1];

       a[i+1] := value2;

     end;

   end;

 end;

 write(a[1]);

end.

Программа написана на PascalABC.net

на free pascal или turbo pascal она может не работать

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика