Написать программу, определяющую возможность представления заданного натурального числа м в виде суммы двух квадратов натуральных чисел.

kazbekkhatitow7h52 kazbekkhatitow7h52    2   09.07.2019 11:30    3

Ответы
Glazkovanuriya Glazkovanuriya  02.10.2020 23:19
Program rabota_01;
var   m, n: Longint;  
i, j: Integer;
begin  
Write('Введите M: '); ReadLn(m);
for i:=Trunc(Sqrt(m)) downto 1 do begin
n:=Sqr(i); j:=1; while (j<=i) and (n+Sqr(j)<m) do Inc(j);    
if n+Sqr(j)=m then begin
WriteLn(m,' = ',i,'^2 + ',j,'^2'); Exit;    
end;
end;  
WriteLn(m,' не является суммой квадратов натуральных чисел.');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика