Написать программу, определяющую количество дней в месяце алгоритм решения : переменная d имеет тип данных запись и содержит два поля: year – для хранения года и month – для месяца. пользователь вводит год и месяц. 8 оператор выбора case по номеру месяца определяет количество дней в нем. ситуация осложняется тем, что в феврале может быть как 28 дней, так и 29 (в високосный год). год является високосным, если делится без остатка на 4 и при этом не является последним годом столетия, за исключением того столетия, которое без остатка делится на 400.

киса822 киса822    2   02.09.2019 14:10    1

Ответы
VIXXX VIXXX  10.08.2020 08:27
Type
   data = record
   year:integer;
   month:byte;
   End;

Var
   d:data;
Begin
Write('Год: ');ReadLn(d.year);
Write('Месяц: ');ReadLn(d.month);
Write('Количество дней в этом месяце: ');
Case d.month of
1,3,5,7,8,10,12:WriteLn(31);
4,6,9,11:WriteLn(30);
2:if (d.year mod 4 = 0)and((d.year mod 100 <> 0)or(d.year mod 400 = 0)) then WriteLn(29)
else WriteLn(28)
End;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика