Написать программу определения суммы двух введенных с клавиатуры чисел. (1 ) составить алгоритм и написать программу для нахождения суммы членов ряда (2 ): s = 5 + 6 + 7 + 8 + 9 + + 28 написать программу определения суммы цифр и количества цифр в заданном натуральном числе. (3 )

Черныйкотик007896 Черныйкотик007896    3   26.05.2019 05:00    7

Ответы
Aruzhka001 Aruzhka001  22.06.2020 14:13
Ээм.. а на каком языке написать то надо?))
ПОКАЗАТЬ ОТВЕТЫ
milka5561 milka5561  22.06.2020 14:13
Program Sum;
Var a, b: Integer;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
WriteLn('Сумма a и b равна ', a + b);
ReadLn;
End.

Program SumRow;
Const min = 5; max = 28;
Var a, i: Integer;
Begin
a := 0;
For i := min To max Do
a := a + i;
WriteLn('Сумма ряда равна ', a);
ReadLn;
End.

Program Digit;
Var a, b: LongInt;
c, d, i: Integer;
Begin
Write('a = ');
ReadLn(a);
b := 1;
c := 0;
While a Div b <> 0 Do
Begin
c := c + 1;
b := b * 10;
End;
While a > 0 Do
Begin
d := d + (a Mod 10);
a := a Div 10;
End;
WriteLn('Количество цифр в числе равно ', c);
WriteLn('Сумма цифр числа равна ', d);
ReadLn;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика