Написать программу определения стоимости разговора по телефону с учётом скидки 20%, предоставляемой по субботам и воскресеньям. входные данные: sm(стоимость минуты разговора), m (число минут), day (день недели - ). выходные данные: s (стоимость разговора). ниже представлен вариант выполнения программы вычисление стоимости телефонного разговора введите исходные данные стоимость минуты разговора, руб. 1 длительность разговора (целое количество минут) 6 день недели (1-понедельник, 7-воскресенье) 7

Sasha0067890 Sasha0067890    1   22.08.2019 11:00    9

Ответы
00Алекс00 00Алекс00  05.10.2020 12:21
Var M, Day : integer; Sm, S : real;
begin
writeln('Вычисление стоимости телефонного разговора');
writeln('Введите исходные данные');
writeln('Стоимость минуты разговора, руб. ');
readln(Sm);
writeln('Длительность разговора (целое количество минут) ');
readln(M);
writeln('День недели (1-понедельник, ... 7-воскресенье) ');
readln(Day);
S:=Sm*M;
if (Day=6)or(Day=7)
 then writeln('Стоимость разговора с учетом скидки = ',S*0.8,' руб')
 else writeln('Стоимость разговора = ',S,' руб');
end.

Пример:
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 
1
Длительность разговора (целое количество минут) 
6
День недели (1-понедельник, ... 7-воскресенье) 
7
Стоимость разговора с учетом скидки = 4.8 руб
ПОКАЗАТЬ ОТВЕТЫ
novakelizaveta71 novakelizaveta71  05.10.2020 12:21
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Вычисление стоимости телефонного разговора');
  Writeln('Введите исходные данные');
  var Sm:=ReadReal('Стоимость минуты разговора, руб.');
  var M:=ReadInteger('Длительность разговора (целое количество минут)');
  var Day:=ReadInteger('День недели (1-понедельник, ... 7-воскресенье)');
  var S:=Sm*M*(Day in [1..5]?1.0:0.8);
  Writeln('Стоимость разговора, руб ',s:0:2)
end.

Пример
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 1
Длительность разговора (целое количество минут) 6
День недели (1-понедельник, ... 7-воскресенье) 7
Стоимость разговора, руб 4.80
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика