Написать программу определения максимального числа последовательности положительных чисел, вводимых с клавиатуры, до тех пор, пока не будет введён 0. (циклом с предусловием в pascalabc), на фото программа с постусловием. а решить надо с предусловием.

arinamarkina0 arinamarkina0    3   14.06.2019 10:18    1

Ответы
Даша145186 Даша145186  02.10.2020 01:51

var x, max: integer;

begin

x:=-1;

max:=-1;

while x<>0 do

 begin

   readln(x);

   if x=0

     then break;

   if x>max

     then max:=x;

 end;

if (max < 1)

 then writeln('Нет чисел, удовлетворяющих условию')

else writeln ('Максимальное число: ', max);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика