tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу о нахождении
Написать программу о нахождении двухзначного числа а.найти сумму и произведение цифр данного числа,а также вывести новое число,в котором цифры числа а поменялись местами
Петя1134
1 09.09.2019 11:30
2
Ответы
botuguruur
01.09.2020 10:47
Var a,a1,a2:integer;
begin
readln(a);
a1:=a div 10;
a2:=a mod 10;
writeln("Сумма цифр = ",a1+a2);
writeln("Произведение цифр = ",a1*a2);
writeln("Число наоборот: ",a2*10+a1);
end.
Пример:
25
Сумма цифр = 7
Произведение цифр = 10
Число наоборот: 52
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Andreyzem4
10.02.2021 19:08
Pascal ABC. Составьте программу, выводящую на экран фрагмент таблицы умножения: 1 x 1 = 12 х 2 = 43 x 3 = 9... 9 х 9 = 81...
anyBeef
10.02.2021 19:08
Напишите программу на языке Паскаль: Y={2*x2-4, если x 3 5*x2+x, если x 3...
ivankirichko2
10.02.2021 19:07
1 вопрос: print (35+5) A 50 B 40 C 35 2 вопрос: print (15 - - 5) A 20 B 10 C 5 3 вопрос: print (13 % 2) A 1 B 6 C 26 4 вопрос print (13//2) A 1 B 6 C 26 5 вопрос import...
Gromozeka1
10.02.2021 19:06
Python На вход программы поступает неизвестное количество чисел целых, ввод заканчивается нулём. Найти среднеарифметическое значение четных чисел....
Мурзиантка
10.02.2021 19:05
Формулировка задачи: Составить программу , которая из слов ВИДЕОАДАПТЕР составляет слова: ДИОД, РАДИО, ПАРТЕР (на python)...
givemepizza
07.11.2020 11:16
Рассказ состоит из 5 страниц, на каждой странице - 50 строк, в каждой строке -40 символов. Каков объем информации в рассказе если использовался 32 символьный алфавит?...
КатяЗюзина
07.11.2020 11:24
Построить динамическую иерархическую модель генеалогического дерева вашей семьи до четвертого поколения по мужской линии....
SAVITAR75657
07.11.2020 11:24
Если на компьютере Windows 7 , по видео нет звука но при этом есть мелодия но нет слов , что делать ? Как быть?...
Ggogog
07.11.2020 11:26
Vba Составить программу, которая вычисляет значение у по заданным значениям аргумента х 2...
izirinee
07.11.2020 11:27
У исполнителя Алго две команды, которым присвоены номера: 1. прибавь 1 2. умножь на b (b — неизвестное натуральное число; b ≥ 2). Выполняя первую из них, Алго увеличивает...
Популярные вопросы
Сообщение изображение петербургской жизни в романе александра сергеевича...
1
Проанализируйте следующие потребности, выделив в них предмет, эмоциональную...
1
По каким признакам можно определить почки в глазках картофеля?...
1
Составить карта путешествия вакулы...
2
20 вставьте пропущенные буквы выр..щенный, возр..ст, выр..с, отр..сль,...
3
Твір на тему вічні образи в античній літературі...
1
Read the text : our dynamic life is full of different activities...
2
Написать эссе или сочинение на тему легко ли быть представителем...
3
Найдите значение суммы всех трехзначных числе кратных 9 остоток...
1
Длина отрезка ав = 6 см. внутри отрезка взята точка м. найдите длину...
3
begin
readln(a);
a1:=a div 10;
a2:=a mod 10;
writeln("Сумма цифр = ",a1+a2);
writeln("Произведение цифр = ",a1*a2);
writeln("Число наоборот: ",a2*10+a1);
end.
Пример:
25
Сумма цифр = 7
Произведение цифр = 10
Число наоборот: 52