Написать программу-найти в массиве из 5 целых чисел номера отрицательных элементов(вывести их на экран), если таких нет, то сообщить об этом

kuznechikmarin kuznechikmarin    1   29.08.2019 06:50    6

Ответы
ksenya64 ksenya64  06.10.2020 02:22
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(5,-20,20); a.Println;
  var s:=a.Select((x,i)->(x,i)).Where(k->k[0]<0);
  if s.Count>0 then s.Select(k->k[1]+1).Println
  else Writeln('Отрицательных элементов нет')
end.

Пример
-6 -16 20 7 -19
1 2 5
ПОКАЗАТЬ ОТВЕТЫ
1945269 1945269  06.10.2020 02:22
#include <iostream>
#include <cstdlib>
#include <ctime>

int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));

int mass[5];
bool op;

printf("Заполнить массив самостоятельно? (1/0): ");
scanf("%d", &op);
for(int i = 0; i < 5; i++){
if(op){
printf("Введите %d-е число: ", i+1),
scanf("%d", &mass[i]);
}else mass[i] = (rand() % 200) - 100;
}
std::cout << std::endl;
int sm = 0;
for(int i = 0; i < 5; i++)
if(mass[i] < 0) printf("%d-й элемент отрицательный: %d\n", i+1, mass[i]), sm++;
if(!sm) printf("В массиве нет отрицательных чисел.");

return EXIT_SUCCESS;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика