Написать программу! найти сумму чётных чисел в интервале от а до в ( а и в - натуральные числа, а< в).

любаня20 любаня20    1   26.06.2019 02:10    3

Ответы
gandurska1 gandurska1  02.10.2020 11:50
uses Crt;
 var a, b, temp, i, S:integer;
 begin
 ClrScr;

 Write (' a = ');   ReadLn(a);
 Write (' b = ');   ReadLn(b);
 S:=0;
 i:=a;
 while i<=b do
   begin
     if (i mod 2 = 0) then S:=S+i;
     i:=i+1;
   end;
 WriteLn(' S = ', S);
 ReadLn;
 end.
ПОКАЗАТЬ ОТВЕТЫ
Нурка11лиса Нурка11лиса  02.10.2020 11:50
Var a,b,i,sum: integer; 
begin 

write ('Введите границы интервала: ');

read (a,b); 

for i:= a to b do 

if i mod 2 = 0 then sum:=sum + i;

writeln ('Сумма четных чисел в интервале от А до Б = ',sum);

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика