Написать программу, . напишите программу, которая находит сумму двухзначных нечетных чисел. последовательность чисел заканчивается числом 0.

ElDiablo1337 ElDiablo1337    3   18.09.2019 15:10    3

Ответы
Mafiy12 Mafiy12  08.10.2020 00:15
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqIntegerWhile(t->t<>0)
      .Where(t->t.IsOdd and t.InRange(10,99)).Sum.Println
end.
ПОКАЗАТЬ ОТВЕТЫ
Alinakozlova2004 Alinakozlova2004  08.10.2020 00:15
Program n1;
var a,sum: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if (a>9) and (a<100) and (a mod 2<>0) then sum:=sum+a;
readln(a);
end;
write(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика