tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу нахождения
Написать программу нахождения в вещественном массиве из 10 элементов, количества отрицательных и превышающих -30.
123291Duck
2 09.07.2019 06:10
1
Ответы
ВасилийПетрович11
16.09.2020 22:16
//Pascal
var
a: array[1..10] of real;
i, count: integer;
begin
count := 0;
write('Исходный массив: ');
for i := 1 to 10 do
begin
{Генерация}
a[i] := random(200) + Random() - 100;
{Вывод}
write(a[i] : 0 : 5, ' ');
{Проверка}
if (a[i] > -30) and (a[i] < 0) then inc(count);
end;
writeln;
writeln('Количество отрицательных элементов, превышающих -30: ', count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Rekryt123
07.09.2019 16:52
Вчем суть регистрации пользователя на почтовом сервере...
ладнобудеттакойник
07.09.2019 18:10
Алфавит для записи сообщения состоит из 32 символов,каков информационный вес слова из 8 букв? указать единицу измерения....
Vlada20981
07.09.2019 18:10
Донки ход на росинанте, сначо панса на осле и ходжа насреддин на верблюде подъехали к реке. там они увидели плот, на котором могут поместиться только двое. животные боятся всех...
аминушечку
17.08.2019 00:20
На остановке останавливаются автобусы с разными номерами. сообщение о том, что подошел автобус № 1 несет 4 бита информации. вероятность появления автобуса № 2 в два раза меньше,...
95308726
17.08.2019 00:20
S=2: i=2 while i 6 s=s+i*(i+1) i=i+1 wend )...
GgEz11134
17.08.2019 00:20
На каких носителях текстовые данные хранили древние люди, а на каких-современные люди?...
user41
17.08.2019 00:20
Разгадайте кроссворд передача информации 4) служба обеспечивающая пересылку сообщений, вещей между отправителем и получателем p.s . не слово почта , что то другое, т.к 10 букв ,...
ПоляКрасавица1
06.05.2020 11:36
пожл! Найди и отметь лишнее устройство в группе: джойстик световое перо мышь тачпад сканер Данное устройство является лишним, так как все остальные устройства являются: устройствами...
Berkutmen
06.05.2020 11:37
Почему код не работает? import pygame pygame.init() screen = pygame.display.set_mode ([360, 320]) screen.fill([255,255,255]) pygame.draw.circle(screen, [93,68,255],[170,60],...
honestt1451
23.12.2020 13:15
Отметь, что входит в устройство 3D-принтера...
Популярные вопросы
Реакция идущая с выделением газа: na₂co₃+hce =...
2
Вычислите 3 целых 11/18 - 1 целая 25/27...
2
Раскройте скобки и подобные слагаемые 0,2(6х-5)-4(0,2х-2) ( )...
3
Найдите решение неравенства |x^2-2x-3|=|3x-7|...
3
Сочинение на тему: роль экологии в жизни общества ....
1
Разложите на множители: а)a^3-4a b)ax^2-ay^2 c)3a^2-6ab+3b^2 d)ax^2+2ax+a...
3
Решить test yourself 5 класс, unit 8 надо, !...
2
Изложите порядок действий пострадавшего в одной из ситуаций после взрыва: человека...
2
1.понятие общество в широком смысле слова означает 1) объединение людей одной...
3
Сочинение описание. описание внешнего вида книги. план. 1) вступление: появления...
3
var
a: array[1..10] of real;
i, count: integer;
begin
count := 0;
write('Исходный массив: ');
for i := 1 to 10 do
begin
{Генерация}
a[i] := random(200) + Random() - 100;
{Вывод}
write(a[i] : 0 : 5, ' ');
{Проверка}
if (a[i] > -30) and (a[i] < 0) then inc(count);
end;
writeln;
writeln('Количество отрицательных элементов, превышающих -30: ', count);
end.