Написать программу нахождения суммы и среднего арифметического значения элементов целочисленного массива размерностью n. С одномерного массива. n равен количеству 5
*размерность - количество элементов массива

миша1078 миша1078    1   06.12.2020 22:39    6

Ответы
Sunnnygirl289 Sunnnygirl289  05.01.2021 22:40

program z1;

const n=5;

var i,s: integer;

a:array[1..n] of integer;

begin

s := 0;

write('Массив : ');

for i:=1 to n do

begin

a[i]:=random(10);

write(a[i]:3);

s:=s+a[i]

end;

writeln;

writeln('Сумма значений элементов целочисленного массива ',s);

writeln('Среднее арифметическое значений элементов целочисленного массива ',s/n)

end.

Объяснение:

n - размерность массива

s - сумма значений элементов

В цикле с параметром:

1) задаём значение элемента массива

2) выводим элемент на экран

3) считаем сумму

Выводим на экран сумму

Выводим на экран среднее арифметическое (делим сумму на количество элементов массива)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика