Написать программу нахождения суммы и произведения всех трехзначных чисел кратных 3!

Dania0609 Dania0609    2   08.05.2019 08:23    7

Ответы
samwwww samwwww  09.06.2020 16:58

program raf105;

var i,sum,pro,a:integer;

begin

writeln('Вводите 5 чисел по очереди');

pro:= 1;

 for i:=1 to 5 do

 begin

  readln(a);

  if (a>=100) and (a<=999) and ((a mod 3)=0)

    then

    begin

    sum+= a;

    pro*= a;

    end;

  end;

writeln('Сумма трёхзначных  чисел кратных трём: ',sum);

writeln('Произведение трёхзначных  чисел кратных трём: ',pro);

end.

Язык PascalABC

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика