Написать программу нахождения наименьшей суммы двух соседних элементов массива

polina1362 polina1362    2   27.07.2019 19:30    1

Ответы
xxx158 xxx158  03.10.2020 14:42
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),10,99); a.Println;
  Writeln('Min. сумма соседних элементов: ',
    a.Pairwise.Select(x->x[0]+x[1]).Min)
end.

Тестовое решение
n= 15
72 22 71 77 41 89 73 54 29 47 47 46 98 82 15
Min. сумма соседних элементов: 76
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика