tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу нахождения
Написать программу нахождения наибольшего общего делителя (нод) двух натуральных чисел.а)использовать оператор repeatб) использовать оператор while
нурбо1
2 29.05.2019 06:10
6
Ответы
Мария12Мария12
27.06.2020 12:55
var a,b: integer;
function NOD(x,y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
end;
begin
readln(a,b);
writeln( 'НОД = ', NOD(a,b) );
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
artyrik412002
01.03.2021 11:56
Определите значение переменной b после выполнения следующего фрагмента программы, в котором a и b - переменные вещественного (действительного) типа....
Fennekin1
01.03.2021 11:56
Напишите что выходит программа на экран У МЕНЯ СОР...
Котполиглот
01.03.2021 11:57
Сор по Информатики 5 класс...
mrsdramaqueen1
01.03.2021 11:58
Задание 2. Оценивается в Составьте программу, которая выводит на экран строку «Программирование в Phyton». Используя тип данных str. Напишите команду, которая выводит данную...
autist1707
09.08.2019 04:00
Внимательно прочитайте предложения. если приглядеться, то буквы нескольких подряд идущих слов образуют термины, связанные с информатикой и компьютерами. найдите их и дайте толкование....
АняЕнот
29.11.2020 15:09
решите Практическая работа №4: Найдите разность между суммой квадратов и квадратом суммы первых ста чисел. Практическая работа №5: Братья Вилли Билли и Дилли пошли на поиски...
1939345
22.06.2019 03:10
Составить программу согласно которой с клавиатуры водятся два числа а компьютер определяет делиться ли первое число на второе...
yaroslav198395
18.09.2019 15:40
Правельно ли тут всё написано? біз отаның гүліміз, тұган жердің нұрылыз. тəуелсіз біздін елікліз. қазақстан-бай жеріміз....
МиссисX2
18.09.2019 15:40
11*. найдите ошибки в образовании прилагательных, запишите их в исправленном виде. а. брат на четыре года младше, чем сестра. б. тесто оказалось жидче, чем предполагала мама....
Polya09062009
18.09.2019 15:40
7ч 9мин - 2ч 53мин + 14ч 48мин 2т 3кг - 4ц 87кг + 9т 96кг надо...
Популярные вопросы
При каких значениях x |7,8-0,4x| в 5 раз меньше чем 20? мне главное правильно...
3
:напишіть будь ласка 5 фразеологізмів...
2
Примеры числительных,которые склоняются как существительные третьего...
1
Сравнение лесостепной зоны и зоны смешаных лесов...
1
Найти наибольшее и наименьшее значение функции на отрезке. f(x)=x⁴/4-8x²...
1
№1 -12 5/6+(-12 1/3)= №2 а)m+n,если m=35,49,n=56,1 б) - 3/8+x,если x=12,7...
3
Назовите интересные факты о достопремечательностях москвы, можно всякие там...
3
Позначити корінь у споріднених словах: галас-галасувати ....
2
Половину решила сама,а вот вторую не 12. he (not to sleep) now. 13. your...
1
1) замените словосочетание «человеческая вера» (предложение 24), построенное...
2
function NOD(x,y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
end;
begin
readln(a,b);
writeln( 'НОД = ', NOD(a,b) );
end.