Написать программу нахождения минимального элемента и его номера в целочисленном массиве. элементы массива заданы случайным образом из промежутка от -10 до 45 на с++,.

savyak444ozb52q savyak444ozb52q    1   05.07.2019 10:50    2

Ответы
IrishkaKoteika2689 IrishkaKoteika2689  28.07.2020 22:20
#include <iostream>
#include <Time.h>
using namespace std;

int main()
{
    int n, i, k;

    cout << "Kolichestvo chisel = ";
    cin >> n;

    srand(time(0));
    int *a = new int[n];

    for (int i = 0; i < n; i++)
    {
        a[i] = rand() % 56 - 10;
        cout << a[i] << " ";
    }
    int min = a[0];

    for (i = 0; i<n; i++)
    if (min>a[i]) {
        min = a[i];
        k = i;
    }

    cout << endl << endl;
    cout << "Min = " << min << endl << "i = " << k << endl;

    system("pause");
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика