Написать программу, находяшую сумму и произведение цифр четырехзначного числа

maximp1699 maximp1699    2   08.10.2019 03:20    1

Ответы
bizi2002 bizi2002  10.10.2020 03:20

var

   a, s, p : integer;

   

begin

   p := 1;

   repeat a := ReadInteger('введите 4-х значное число: ') until (a > 999) and (a < 10000);

   while a > 0 do begin      

       s += a mod 10;

       p *= a mod 10;

       a := a div 10;

   end;

   writeln('сумма ', s);

   writeln('произведение ', p);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика